5411 C# Programming Manual: D:/5411/C# Directory Reference

5411 C# Programming Manual
C# Directory Reference

Files

file | JY5411DITask.cs
file | JY5411DOTask.cs
Generated by doxygen 1.9.1


5411 C# Programming Manual: D:/5411/C#/JY5411DITask.cs File Reference

Classes | Namespaces | Enumerations
JY5411DITask.cs File Reference

Classes

class | JY5411.JY5411DITask
class | JY5411.DIChannel
class | JY5411.DISampleClock
Sample clock configuration class More...
class | JY5411.DIExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5411.DITrigger
class | JY5411.DIDigitalTrigger
class | JY5411.DISignalExport
DI Signal Export Class More...
class | JY5411.DIRecord
AI Record Parameters. More...

Namespaces

namespace JY5411

Enumerations

enum class | JY5411.DIMode { JY5411.Single = JY5411Import.JY5411_DI_Single , JY5411.Finite = JY5411Import.JY5411_DI_Finite , JY5411.Continuous = JY5411Import.JY5411_DI_Continuous , JY5411.Record = JY5411Import.JY5411_DI_Record }
enum class | JY5411.DISampleClockSource { JY5411.Internal = JY5411Import.JY5411_DIO_InternalSampleClock , JY5411.External = JY5411Import.JY5411_DIO_ExternalSampleClock }
enum class JY5411.ClockTerminal {
JY5411.PXIe_DStarA = JY5411Import.JY5411_DIO_PXIe_DStarA , JY5411.PXIe_DStarB = JY5411Import.JY5411_DIO_PXIe_DStarB , JY5411.PXI_Star = JY5411Import.JY5411_DIO_PXI_Star , JY5411.PXIe_Sync100 = JY5411Import.JY5411_DIO_PXIe_SYNC100 ,
JY5411.PXI_Trig0 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_0 , JY5411.PXI_Trig1 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_1 , JY5411.PXI_Trig2 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_2 , JY5411.PXI_Trig3 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_3 ,
JY5411.PXI_Trig4 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_4 , JY5411.PXI_Trig5 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_5 , JY5411.PXI_Trig6 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_6 , JY5411.PXI_Trig7 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_7 ,
JY5411.PFI0 = JY5411Import.JY5411_DIO_ExternalClock_PFI0 , JY5411.PFI1 = JY5411Import.JY5411_DIO_ExternalClock_PFI_1 , JY5411.PFI2 = JY5411Import.JY5411_DIO_ExternalClock_PFI_2 , JY5411.PFI3 = JY5411Import.JY5411_DIO_ExternalClock_PFI_3 ,
JY5411.PFI4 = JY5411Import.JY5411_DIO_ExternalClock_PFI_4 , JY5411.PFI5 = JY5411Import.JY5411_DIO_ExternalClock_PFI_5 , JY5411.PFI6 = JY5411Import.JY5411_DIO_ExternalClock_PFI_6 , JY5411.PFI7 = JY5411Import.JY5411_DIO_ExternalClock_PFI_7 ,
JY5411.DI_SampleClock = JY5411Import.JY5411_DI_SampleClock_Out , JY5411.DO_SampleClock = JY5411Import.JY5411_DO_SampleClock_Out
}
External Sample Clock Terminal More...
enum class | JY5411.ClockEdge { JY5411.Rising = JY5411Import.JY5411_RISING_EDGE , JY5411.Falling = JY5411Import.JY5411_FALLING_EDGE }
ClockEdge enumeration type More...
enum class | JY5411.DITriggerType { JY5411.Immediately = JY5411Import.JY5411_TriggerType_Immediately , JY5411.Digital = JY5411Import.JY5411_TriggerType_Digital , JY5411.Soft = JY5411Import.JY5411_TriggerType_Soft }
enum class | JY5411.DITriggerMode { JY5411.Start = JY5411Import.JY5411_DI_StartTrigger , JY5411.Reference = JY5411Import.JY5411_DI_ReferenceTrigger }
enum class JY5411.DIDigitalTriggerSource {
JY5411.PFI0 = JY5411Import.JY5411_DigitalTriggerSource_PFI0 , JY5411.PFI1 = JY5411Import.JY5411_DigitalTriggerSource_PFI_1 , JY5411.PFI2 = JY5411Import.JY5411_DigitalTriggerSource_PFI_2 , JY5411.PFI3 = JY5411Import.JY5411_DigitalTriggerSource_PFI_3 ,
JY5411.PFI4 = JY5411Import.JY5411_DigitalTriggerSource_PFI_4 , JY5411.PFI5 = JY5411Import.JY5411_DigitalTriggerSource_PFI_5 , JY5411.PFI6 = JY5411Import.JY5411_DigitalTriggerSource_PFI_6 , JY5411.PFI7 = JY5411Import.JY5411_DigitalTriggerSource_PFI_7 ,
JY5411.PXI_Trig0 = JY5411Import.JY5411_DigitalTriggerSource_PXI_0 , JY5411.PXI_Trig1 = JY5411Import.JY5411_DigitalTriggerSource_PXI_1 , JY5411.PXI_Trig2 = JY5411Import.JY5411_DigitalTriggerSource_PXI_2 , JY5411.PXI_Trig3 = JY5411Import.JY5411_DigitalTriggerSource_PXI_3 ,
JY5411.PXI_Trig4 = JY5411Import.JY5411_DigitalTriggerSource_PXI_4 , JY5411.PXI_Trig5 = JY5411Import.JY5411_DigitalTriggerSource_PXI_5 , JY5411.PXI_Trig6 = JY5411Import.JY5411_DigitalTriggerSource_PXI_6 , JY5411.PXI_Trig7 = JY5411Import.JY5411_DigitalTriggerSource_PXI_7 ,
JY5411.DO_StartTrig = JY5411Import.JY5411_DO_StartTriggerOut
}
enum class | JY5411.DIDigitalTriggerEdge { JY5411.Rising = JY5411Import.JY5411_DigitalTriggerEdge_Rising , JY5411.Falling = JY5411Import.JY5411_DigitalTriggerEdge_Falling }
enum class | JY5411.DISignalExportSource { JY5411.SampleClock = JY5411Import.JY5411_DI_SampleCLK_Out , JY5411.StartTrig = JY5411Import.JY5411_DI_Start_trigger_out , JY5411.ReferenceTrig = JY5411Import.JY5411_DI_Reference_trigger_out }
enum class JY5411.SignalExportDestination {
JY5411.PFI0 = JY5411Import.JY5411_Terminal_PFI_0 , JY5411.PFI1 = JY5411Import.JY5411_Terminal_PFI_1 , JY5411.PFI2 = JY5411Import.JY5411_Terminal_PFI_2 , JY5411.PFI3 = JY5411Import.JY5411_Terminal_PFI_3 ,
JY5411.PFI4 = JY5411Import.JY5411_Terminal_PFI_4 , JY5411.PFI5 = JY5411Import.JY5411_Terminal_PFI_5 , JY5411.PFI6 = JY5411Import.JY5411_Terminal_PFI_6 , JY5411.PFI7 = JY5411Import.JY5411_Terminal_PFI_7 ,
JY5411.PXI_Trig0 = JY5411Import.JY5411_Terminal_PXITriggerBus0 , JY5411.PXI_Trig1 = JY5411Import.JY5411_Terminal_PXITriggerBus1 , JY5411.PXI_Trig2 = JY5411Import.JY5411_Terminal_PXITriggerBus2 , JY5411.PXI_Trig3 = JY5411Import.JY5411_Terminal_PXITriggerBus3 ,
JY5411.PXI_Trig4 = JY5411Import.JY5411_Terminal_PXITriggerBus4 , JY5411.PXI_Trig5 = JY5411Import.JY5411_Terminal_PXITriggerBus5 , JY5411.PXI_Trig6 = JY5411Import.JY5411_Terminal_PXITriggerBus6 , JY5411.PXI_Trig7 = JY5411Import.JY5411_Terminal_PXITriggerBus7
}
enum class | JY5411.FileFormat { JY5411.Bin }
Streaming file format. enum BIN. More...
enum class | JY5411.RecordMode { JY5411.Finite , JY5411.Infinite }
stream mode .enum Finite/Infinite More...


5411 C# Programming Manual: JY5411.JY5411DITask Class Reference

  • JY5411
  • JY5411DITask
Public Member Functions | Properties | List of all members
JY5411.JY5411DITask Class Reference

More...

Public Member Functions

JY5411DITask (int slotNum)
JY5411DITask (string boardName)
void | AddChannel (int lineNum)
void | AddChannel (int[] linesNum)
void | RemoveChannel (int lineNum)
void | SendSoftwareTrigger ()
void | ReadSinglePoint (ref bool[] readValues)
void | ReadSinglePoint (ref bool readValue, int lineNum)
void | ReadData (ref uint[] buf, uint samplesToAcquire, int timeOut=10000)
void | ReadData (IntPtr buf, uint samplesToAcquire, int timeOut=10000)
void | ReadData (ref uint[] buf, int timeOut=10000)
void | ReadData (ref byte[,] buf, uint samplesPerChannel, int timeOut)
void | ReadData (ref byte[] buf, uint samplesPerChannel, int timeOut)
void | GetRecordPreviewData (ref uint[] buf, int samplesPerChannel, int timeout=1000)
void | GetRecordPreviewData (ref uint[] buf, int timeout=1000)
void | GetRecordPreviewData (ref byte[,] buf, int samplesPerChannel, int timeout=1000)
void | GetRecordPreviewData (ref byte[] buf, uint samplesPerChannel, int timeout=1000)
void | GetRecordStatus (out double recordedLength, out bool recordDone)
void | Start ()
void | Stop ()

Properties

List< DIChannel > | Channels [get, set]
JY5411Device | Device [get]
JY5411Device More...
DIMode | Mode [get, set]
DISampleClock | SampleClock [get, set]
double | SampleRate [get, set]
int | SamplesToAcquire [get, set]
ulong | AvailableSamples [get]
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value. More...
DITrigger | Trigger [get, set]
DIRecord | Record = new DIRecord() [get]
di Data streaming Configuration More...
DISignalExport | SignalExport [get, set]
Export DI Signal More...

Detailed Description

JY5411数字输入任务

JY5411 DITask Input Task.

Constructor & Destructor Documentation

◆ JY5411DITask() [1/2]

JY5411.JY5411DITask.JY5411DITask ( int slotNum )

用卡槽号创建一个DITask

Create a DITask with a slot number

Parameters
slotNum 板卡槽位号Slot Number

◆ JY5411DITask() [2/2]

JY5411.JY5411DITask.JY5411DITask ( string boardName )

用板卡名称创建一个DITask

Create a DITask with a boardName

Parameters
boardName 板卡名称boardName

Member Function Documentation

◆ AddChannel() [1/2]

void JY5411.JY5411DITask.AddChannel ( int lineNum )

添加单通道

add single channel

Parameters
lineNum 通道编号lineID

◆ AddChannel() [2/2]

void JY5411.JY5411DITask.AddChannel ( int[] linesNum )

添加多通道

add muliti channel

Parameters
linesNum 通道编号数组lineID

◆ GetRecordPreviewData() [1/4]

void JY5411.JY5411DITask.GetRecordPreviewData | ( | ref byte | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

预览字节类型样点值，每一列代表一个通道

Preview multi-channel data when streaming is in progress. Each column represents one channel.

Parameters
buf 样点值readValue
timeOut 超时时间
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [2/4]

void JY5411.JY5411DITask.GetRecordPreviewData | ( | ref byte[] | buf,
 |  | uint | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

预览单通道字节类型样点值

Preview one channel data when streaming is in progress.

Parameters
buf 样点值readValue
timeOut 超时时间
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [3/4]

void JY5411.JY5411DITask.GetRecordPreviewData | ( | ref uint[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

预览uint类型样点值

Preview multi-channel data when streaming is in progress. Each column represents one channel.

Parameters
buf | 样点值readValue
samplesPerChannel | 采样点数Number of samples per line to be read
timeOut 超时时间
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordPreviewData() [4/4]

void JY5411.JY5411DITask.GetRecordPreviewData | ( | ref uint[] | buf,
 |  | int | timeout = 1000
 | ) |  |

预览uint类型样点值

Preview multi-channel data when streaming is in progress. Each column represents one channel.

Parameters
buf 样点值readValue
timeOut 超时时间
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ GetRecordStatus()

void JY5411.JY5411DITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone
 | ) |  |

获取流盘状态

Get the streaming status.

Parameters
recordedLength | 已经流盘的长度，单位是秒Length of the streamed, unit s
recordDone | 流盘结束的标志，为false时，流盘未结束，为true时，流盘结束recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData() [1/5]

void JY5411.JY5411DITask.ReadData | ( | IntPtr | buf,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000
 | ) |  |

读取样点值

the buffer of save data

Parameters
buf | 样点值readValue
samplesToAcquire | 采样点数samplesToAcquire
timeOut | 超时时间timeOut

◆ ReadData() [2/5]

void JY5411.JY5411DITask.ReadData | ( | ref byte | buf[,],
 |  | uint | samplesPerChannel,
 |  | int | timeOut
 | ) |  |

读取字节类型样点值,每一列代表一个通道

Read the line byte data from the lines. Each column represents one line.

Parameters
buf | 样点值readValue
samplesPerChannel | 采样点数Number of samples per port to be read
timeOut 超时时间
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/5]

void JY5411.JY5411DITask.ReadData | ( | ref byte[] | buf,
 |  | uint | samplesPerChannel,
 |  | int | timeOut
 | ) |  |

读取单通道字节类型样点值

Read the byte data from one line.

Parameters
buf | 样点值readValue
samplesPerChannel | 采样点数Number of samples per line to be read
timeOut | 超时时间timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [4/5]

void JY5411.JY5411DITask.ReadData | ( | ref uint[] | buf,
 |  | int | timeOut = 10000
 | ) |  |

从缓冲区读取样点值

Read the uint data from one line or multi-lines.

Parameters
buf 样点值,Uint类型,每一位代表一个通道readValue
timeOut 超时时间
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [5/5]

void JY5411.JY5411DITask.ReadData | ( | ref uint[] | buf,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000
 | ) |  |

从缓冲区读取样点值

Read the uint data from one line or multi-lines.

Parameters
buf | 样点值,Uint类型,每一位代表一个通道readValue
samplesToAcquire | 采样点数Number of samples per line to be read
timeOut 超时时间
Parameters
timeOut timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY5411.JY5411DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | lineNum
 | ) |  |

从寄存器读取样点值。当 Type 为 DIMode.Single时可用。

Read a signle count value from register. Available when Type is DIMode.Single时可用。

Parameters
readValue | 样点值Values read.
lineNum | 通道编号Specified line numbers.

◆ ReadSinglePoint() [2/2]

void JY5411.JY5411DITask.ReadSinglePoint ( ref bool[] readValues )

从寄存器读取样点值。当 Type 为 DIMode.Single时可用。

Read a signle count value from register. Available when Type is DIMode.Single时可用。

Parameters
readValues 存储样点值的数组，每个通道读取一个bool值Values read. Buffer size >= number of channels.

◆ RemoveChannel()

void JY5411.JY5411DITask.RemoveChannel ( int lineNum )

删除单通道

Delete the specified line number

Parameters
lineNum 通道编号lineID

◆ SendSoftwareTrigger()

void JY5411.JY5411DITask.SendSoftwareTrigger ( )

发送软件触发

SendSoftwareTrigger

◆ Start()

void JY5411.JY5411DITask.Start ( )

启动DI任务

Start DI task

◆ Stop()

void JY5411.JY5411DITask.Stop ( )

停止DI任务

Stop DITask

Property Documentation

◆ AvailableSamples

ulong JY5411.JY5411DITask.AvailableSamples
get

缓冲区内可以读取的每通道点数。当 Mode 不为 DIMode.Single 时有效。

Number of samples per channel that can be read from the buffer. Valid when Mode is NOT DIMode.Single.

◆ BufLenInSamples

int JY5411.JY5411DITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<DIChannel> JY5411.JY5411DITask.Channels
getset

DI通道

DIChannel List

◆ Device

JY5411Device JY5411.JY5411DITask.Device
get

JY5411Device

◆ Mode

DIMode JY5411.JY5411DITask.Mode
getset

采集模式

Acquisition mode, support Single/Finite/Continuous three types

◆ Record

DIRecord JY5411.JY5411DITask.Record = new DIRecord()
get

di Data streaming Configuration

◆ SampleClock

DISampleClock JY5411.JY5411DITask.SampleClock
getset

采样时钟

Clock source, supports both internal and external types

◆ SampleRate

double JY5411.JY5411DITask.SampleRate
getset

采样率

Sample rate per channel, maximum sampling rate is 50MHz

◆ SamplesToAcquire

int JY5411.JY5411DITask.SamplesToAcquire
getset

每通道采集的样点数。当 Mode 为 DIMode.Finite 时有效。

Number of samples to be acquired per channel. Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport JY5411.JY5411DITask.SignalExport
getset

Export DI Signal

◆ TransferedSamples

ulong JY5411.JY5411DITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode.Single.

◆ Trigger

DITrigger JY5411.JY5411DITask.Trigger
getset

触发

configure DITask trigger param

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DITask.cs


5411 C# Programming Manual: JY5411.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5411.DIChannel Class Reference

More...

Properties

int LineNum [get, set]

Detailed Description

通道类

DIChannel class

Property Documentation

◆ LineNum

int JY5411.DIChannel.LineNum
getset

通道编号

LineID

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DITask.cs


5411 C# Programming Manual: JY5411.DISampleClock Class Reference

  • DISampleClock
Properties | List of all members
JY5411.DISampleClock Class Reference

Sample clock configuration class More...

Properties

DISampleClockSource | Source [get, set]
Clock Source. More...
DIExternalSampleClock | External [get, set]
External Sample Clock More...
ClockEdge | Edge [get, set]
Clock Edge More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ Edge

ClockEdge JY5411.DISampleClock.Edge
getset

Clock Edge

◆ External

DIExternalSampleClock JY5411.DISampleClock.External
getset

External Sample Clock

◆ Source

DISampleClockSource JY5411.DISampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DITask.cs


5411 C# Programming Manual: JY5411.DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Properties | List of all members
JY5411.DIExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5411.DIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5411.DIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DITask.cs


5411 C# Programming Manual: JY5411.DITrigger Class Reference

  • DITrigger
Properties | List of all members
JY5411.DITrigger Class Reference

More...

Properties

DITriggerMode | Mode [get, set]
Trigger mode, including Start/Reference More...
DITriggerType | Type [get, set]
Trigger type, including: Immediate/Digital More...
DIDigitalTrigger | Digital [get, set]
Digital trigger setting More...
int | ReTriggerCount [get, set]
ReTriggerCount More...
uint | PreTriggerSamples [get, set]
the number of points before the trigger should be set to 0 using the hardware's immediate trigger or delayed trigger mode Use hardware pre-trigger or intermediate trigger mode should set it to the number of points to be collected before triggering More...
uint | Delay [get, set]
DIDigitalTrigger delay，Unit:Sample More...

Detailed Description

触发模式

DI trigger parameter configuration class

Property Documentation

◆ Delay

uint JY5411.DITrigger.Delay
getset

DIDigitalTrigger delay，Unit:Sample

◆ Digital

DIDigitalTrigger JY5411.DITrigger.Digital
getset

Digital trigger setting

◆ Mode

DITriggerMode JY5411.DITrigger.Mode
getset

Trigger mode, including Start/Reference

◆ PreTriggerSamples

uint JY5411.DITrigger.PreTriggerSamples
getset

the number of points before the trigger should be set to 0 using the hardware's immediate trigger or delayed trigger mode Use hardware pre-trigger or intermediate trigger mode should set it to the number of points to be collected before triggering

◆ ReTriggerCount

int JY5411.DITrigger.ReTriggerCount
getset

ReTriggerCount

◆ Type

DITriggerType JY5411.DITrigger.Type
getset

Trigger type, including: Immediate/Digital

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DITask.cs


5411 C# Programming Manual: JY5411.DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Properties | List of all members
JY5411.DIDigitalTrigger Class Reference

More...

Properties

DIDigitalTriggerSource | Source [get, set]
DIDigitalTriggerSource More...
DIDigitalTriggerEdge | Edge [get, set]
DIDigitalTriggerEdge，Rising/Falling More...

Detailed Description

数字触发

DI digital trigger setting parameter definition

Property Documentation

◆ Edge

DIDigitalTriggerEdge JY5411.DIDigitalTrigger.Edge
getset

DIDigitalTriggerEdge，Rising/Falling

◆ Source

DIDigitalTriggerSource JY5411.DIDigitalTrigger.Source
getset

DIDigitalTriggerSource

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DITask.cs


5411 C# Programming Manual: JY5411.DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5411.DISignalExport Class Reference

DI Signal Export Class More...

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (DISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

DI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5411.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | DI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5411.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | DI Signal Source
destination | Export Desination

◆ Clear()

void JY5411.DISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5411.DISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DITask.cs


5411 C# Programming Manual: JY5411.DIRecord Class Reference

  • DIRecord
Properties | List of all members
JY5411.DIRecord Class Reference

AI Record Parameters. More...

Properties

string | FilePath [get, set]
User specified file path. More...
FileFormat | FileFormat [get]
Streaming file format. More...
RecordMode | Mode [get, set]
stream mode . More...
double | Length [get, set]
User specified stream length in second. More...

Detailed Description

AI Record Parameters.

Property Documentation

◆ FileFormat

FileFormat JY5411.DIRecord.FileFormat
get

Streaming file format.

enum BIN.

◆ FilePath

string JY5411.DIRecord.FilePath
getset

User specified file path.

◆ Length

double JY5411.DIRecord.Length
getset

User specified stream length in second.

Only when Mode is RecordMode.Finite.

◆ Mode

RecordMode JY5411.DIRecord.Mode
getset

stream mode .

enum Finite/Infinite.

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DITask.cs


5411 C# Programming Manual: D:/5411/C#/JY5411DOTask.cs File Reference

Classes | Namespaces | Enumerations
JY5411DOTask.cs File Reference

Classes

class | JY5411.JY5411DOTask
DOTask class More...
class | JY5411.DOChannel
DOChannel class More...
class | JY5411.DOSampleClock
Sample clock configuration class More...
class | JY5411.DOExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5411.DOTrigger
DOTrigger enumeration type More...
class | JY5411.DODigitalTrigger
DODigitalTrigger enumeration type More...
class | JY5411.DOSignalExport
DO Signal Export Class More...

Namespaces

namespace JY5411

Enumerations

enum class | JY5411.DOSampleClockSource { JY5411.Internal = JY5411Import.JY5411_DIO_InternalSampleClock , JY5411.External = JY5411Import.JY5411_DIO_ExternalSampleClock }
enum class | JY5411.DOMode { JY5411.Single = JY5411Import.JY5411_DO_Single , JY5411.Finite = JY5411Import.JY5411_DO_Finite , JY5411.ContinuousWrapping = JY5411Import.JY5411_DO_ContinuousWrapping , JY5411.ContinuousNoWrapping = JY5411Import.JY5411_DO_ContinuousNoWrapping }
DOTask mode enumeration type More...
enum class | JY5411.DODigitalTriggerEdge { JY5411.Rising = JY5411Import.JY5411_DigitalTriggerEdge_Rising , JY5411.Falling = JY5411Import.JY5411_DigitalTriggerEdge_Falling }
DODigitalTriggerEdge enumeration type More...
enum class JY5411.DODigitalTriggerSource {
JY5411.PFI0 = JY5411Import.JY5411_DigitalTriggerSource_PFI0 , JY5411.PFI1 = JY5411Import.JY5411_DigitalTriggerSource_PFI_1 , JY5411.PFI2 = JY5411Import.JY5411_DigitalTriggerSource_PFI_2 , JY5411.PFI3 = JY5411Import.JY5411_DigitalTriggerSource_PFI_3 ,
JY5411.PFI4 = JY5411Import.JY5411_DigitalTriggerSource_PFI_4 , JY5411.PFI5 = JY5411Import.JY5411_DigitalTriggerSource_PFI_5 , JY5411.PFI6 = JY5411Import.JY5411_DigitalTriggerSource_PFI_6 , JY5411.PFI7 = JY5411Import.JY5411_DigitalTriggerSource_PFI_7 ,
JY5411.PXI_Trig0 = JY5411Import.JY5411_DigitalTriggerSource_PXI_0 , JY5411.PXI_Trig1 = JY5411Import.JY5411_DigitalTriggerSource_PXI_1 , JY5411.PXI_Trig2 = JY5411Import.JY5411_DigitalTriggerSource_PXI_2 , JY5411.PXI_Trig3 = JY5411Import.JY5411_DigitalTriggerSource_PXI_3 ,
JY5411.PXI_Trig4 = JY5411Import.JY5411_DigitalTriggerSource_PXI_4 , JY5411.PXI_Trig5 = JY5411Import.JY5411_DigitalTriggerSource_PXI_5 , JY5411.PXI_Trig6 = JY5411Import.JY5411_DigitalTriggerSource_PXI_6 , JY5411.PXI_Trig7 = JY5411Import.JY5411_DigitalTriggerSource_PXI_7 ,
JY5411.DI_StartTrig = JY5411Import.JY5411_DI_StartTriggerOut , JY5411.DI_ReferenceTrig = JY5411Import.JY5411_DI_ReferenceTriggerOut
}
DODigitalTriggerSource enumeration type More...
enum class | JY5411.DOTriggerType { JY5411.Immediately = JY5411Import.JY5411_TriggerType_Immediately , JY5411.Digital = JY5411Import.JY5411_TriggerType_Digital , JY5411.Soft = JY5411Import.JY5411_TriggerType_Soft }
DOTriggerType enumeration type More...
enum class | JY5411.DOSignalExportSource { JY5411.SampleClock = JY5411Import.JY5411_DO_SampleClock_Out , JY5411.StartTrig = JY5411Import.JY5411_DO_StartTriggerOut }
JY5411_DO_SourceSignal More...


5411 C# Programming Manual: JY5411.JY5411DOTask Class Reference

  • JY5411DOTask
Public Member Functions | Properties | List of all members
JY5411.JY5411DOTask Class Reference

DOTask class More...

Public Member Functions

JY5411DOTask (int slotNum)
JY5411DOTask More...
JY5411DOTask (string boardName)
void | AddChannel (int lineNum)
add single channel More...
void | AddChannel (int[] linesNum)
Add multiple channels More...
void | RemoveChannel (int lineNum)
Delete the specified line number .If it is -1, delete all lines. More...
void | WriteSinglePoint (bool[] writeValues)
write one sample to all lines in register . More...
void | WriteSinglePoint (bool writeValue, int lineNum)
Write one sample to the specified line in register.Available when Mode is DOMode.Single More...
void | SendSoftwareTrigger ()
SendSoftwareTrigger More...
void | Start ()
Start DOTask More...
void | Stop ()
Stop DOTask More...
bool | WaitUntilDone ()
Waiting for the current task to complete More...
void | WriteData (uint[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the uint data from one line or multi-lines. More...
void | WriteData (IntPtr dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the data from one line or multi-lines. More...
void | WriteData (uint[] dataBuffer, int timeOut=10000)
Write the uint data from one line or multi-lines. More...
void | WriteData (byte[,] dataBuffer, uint samplesPerChannel, int timeOut=10000)
write the line byte data to the lines. More...
void | WriteData (byte[] dataBuffer, uint samplesPerChannel, int timeOut=10000)
wirte the byte data to one line. More...

Properties

List< DOChannel > | Channels [get, set]
DOChannel list More...
JY5411Device | Device [get]
JY5411Device More...
DOMode | Mode [get, set]
DOMode,Support Single/Finite/ContinuousWrapping/ContinuousNoWrapping More...
double | UpdateRate [get, set]
Update rate per channel, maximum is 50MHz More...
int | SamplesToUpdate [get, set]
The number of samples output per channel when finite point output More...
DOSampleClock | SampleClock [get, set]
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToUpdate must be less than or equal to this value. More...
uint | availableLenInSamples [get]
The number of samples currently available in the local buffer (the current number of samples that can be written to the buffer per channel) More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
DOTrigger | Trigger [get, set]
configure DOTask trigger param More...
DOSignalExport | SignalExport [get, set]
Export DO Signal More...

Detailed Description

DOTask class

Constructor & Destructor Documentation

◆ JY5411DOTask() [1/2]

JY5411.JY5411DOTask.JY5411DOTask ( int slotNum )

JY5411DOTask

Parameters
slotNum board slotNum

◆ JY5411DOTask() [2/2]

JY5411.JY5411DOTask.JY5411DOTask ( string boardName )

JY5411DOTask构造函数，用来构造一个DO任务对象

Constructor. Used to create an DOtask object.

Parameters
boardName 板卡名称。Card Name.

Member Function Documentation

◆ AddChannel() [1/2]

void JY5411.JY5411DOTask.AddChannel ( int lineNum )

add single channel

Parameters
lineNum line number to be added.

◆ AddChannel() [2/2]

void JY5411.JY5411DOTask.AddChannel ( int[] linesNum )

Add multiple channels

Parameters
linesNum an array of line numbers of added lines.

◆ RemoveChannel()

void JY5411.JY5411DOTask.RemoveChannel ( int lineNum )

Delete the specified line number .If it is -1, delete all lines.

Parameters
lineNum line number to be delete.

◆ SendSoftwareTrigger()

void JY5411.JY5411DOTask.SendSoftwareTrigger ( )

SendSoftwareTrigger

Returns

◆ Start()

void JY5411.JY5411DOTask.Start ( )

Start DOTask

◆ Stop()

void JY5411.JY5411DOTask.Stop ( )

Stop DOTask

◆ WaitUntilDone()

bool JY5411.JY5411DOTask.WaitUntilDone ( )

Waiting for the current task to complete

◆ WriteData() [1/5]

void JY5411.JY5411DOTask.WriteData | ( | byte | dataBuffer[,],
 |  | uint | samplesPerChannel,
 |  | int | timeOut = 10000
 | ) |  |

write the line byte data to the lines.

Each column represents one line.

Parameters
dataBuffer | Data buffer
samplesPerChannel | Number of samples per line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/5]

void JY5411.JY5411DOTask.WriteData | ( | byte[] | dataBuffer,
 |  | uint | samplesPerChannel,
 |  | int | timeOut = 10000
 | ) |  |

wirte the byte data to one line.

Parameters
dataBuffer | Data buffer
samplesPerChannel | Number of samples per line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/5]

void JY5411.JY5411DOTask.WriteData | ( | IntPtr | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000
 | ) |  |

Write the data from one line or multi-lines.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [4/5]

void JY5411.JY5411DOTask.WriteData | ( | uint[] | dataBuffer,
 |  | int | timeOut = 10000
 | ) |  |

Write the uint data from one line or multi-lines.

Parameters
dataBuffer | Data buffer
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [5/5]

void JY5411.JY5411DOTask.WriteData | ( | uint[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000
 | ) |  |

Write the uint data from one line or multi-lines.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5411.JY5411DOTask.WriteSinglePoint | ( | bool | writeValue,
 |  | int | lineNum
 | ) |  |

Write one sample to the specified line in register.Available when Mode is DOMode.Single

Parameters
writeValue | Write value.
lineNum | Specified line.

◆ WriteSinglePoint() [2/2]

void JY5411.JY5411DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all lines in register .

Available when Mode is DOMode.Single

Parameters
writeValues write Values.Buffer size >= number of lines。

Property Documentation

◆ availableLenInSamples

uint JY5411.JY5411DOTask.availableLenInSamples
get

The number of samples currently available in the local buffer (the current number of samples that can be written to the buffer per channel)

◆ BufLenInSamples

int JY5411.JY5411DOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToUpdate must be less than or equal to this value.

◆ Channels

List<DOChannel> JY5411.JY5411DOTask.Channels
getset

DOChannel list

◆ Device

JY5411Device JY5411.JY5411DOTask.Device
get

JY5411Device

◆ Mode

DOMode JY5411.JY5411DOTask.Mode
getset

DOMode,Support Single/Finite/ContinuousWrapping/ContinuousNoWrapping

◆ SampleClock

DOSampleClock JY5411.JY5411DOTask.SampleClock
getset

采样时钟

Clock source, supports both internal and external types

◆ SamplesToUpdate

int JY5411.JY5411DOTask.SamplesToUpdate
getset

The number of samples output per channel when finite point output

◆ SignalExport

DOSignalExport JY5411.JY5411DOTask.SignalExport
getset

Export DO Signal

◆ TransferedSamples

ulong JY5411.JY5411DOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DOMode.Single.

◆ Trigger

DOTrigger JY5411.JY5411DOTask.Trigger
getset

configure DOTask trigger param

◆ UpdateRate

double JY5411.JY5411DOTask.UpdateRate
getset

Update rate per channel, maximum is 50MHz

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DOTask.cs


5411 C# Programming Manual: JY5411.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5411.DOChannel Class Reference

DOChannel class More...

Properties

int LineNum [get, set]
LineID More...

Detailed Description

DOChannel class

Property Documentation

◆ LineNum

int JY5411.DOChannel.LineNum
getset

LineID

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DOTask.cs


5411 C# Programming Manual: JY5411.DOSampleClock Class Reference

  • DOSampleClock
Properties | List of all members
JY5411.DOSampleClock Class Reference

Sample clock configuration class More...

Properties

DOSampleClockSource | Source [get, set]
Clock Source. More...
DOExternalSampleClock | External [get, set]
External Sample Clock More...
ClockEdge | Edge [get, set]
Clock Edge More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ Edge

ClockEdge JY5411.DOSampleClock.Edge
getset

Clock Edge

◆ External

DOExternalSampleClock JY5411.DOSampleClock.External
getset

External Sample Clock

◆ Source

DOSampleClockSource JY5411.DOSampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DOTask.cs


5411 C# Programming Manual: JY5411.DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Properties | List of all members
JY5411.DOExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5411.DOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5411.DOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DOTask.cs


5411 C# Programming Manual: JY5411.DOTrigger Class Reference

  • DOTrigger
Properties | List of all members
JY5411.DOTrigger Class Reference

DOTrigger enumeration type More...

Properties

DOTriggerType | Type [get, set]
DOTriggerType：Immediate/Digital More...
DODigitalTrigger | Digital [get, set]
DODigitalTrigger More...
uint | Delay [get, set]
DODigitalTrigger delay，Unit:Sample More...

Detailed Description

DOTrigger enumeration type

Property Documentation

◆ Delay

uint JY5411.DOTrigger.Delay
getset

DODigitalTrigger delay，Unit:Sample

◆ Digital

DODigitalTrigger JY5411.DOTrigger.Digital
getset

DODigitalTrigger

◆ Type

DOTriggerType JY5411.DOTrigger.Type
getset

DOTriggerType：Immediate/Digital

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DOTask.cs


5411 C# Programming Manual: JY5411.DODigitalTrigger Class Reference

  • DODigitalTrigger
Properties | List of all members
JY5411.DODigitalTrigger Class Reference

DODigitalTrigger enumeration type More...

Properties

DODigitalTriggerSource | Source [get, set]
DODigitalTriggerSource More...
DODigitalTriggerEdge | Edge [get, set]
DODigitalTriggerEdge，Rising/Falling More...

Detailed Description

DODigitalTrigger enumeration type

Property Documentation

◆ Edge

DODigitalTriggerEdge JY5411.DODigitalTrigger.Edge
getset

DODigitalTriggerEdge，Rising/Falling

◆ Source

DODigitalTriggerSource JY5411.DODigitalTrigger.Source
getset

DODigitalTriggerSource

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DOTask.cs


5411 C# Programming Manual: JY5411.DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5411.DOSignalExport Class Reference

DO Signal Export Class More...

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (DOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

DO Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5411.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | DO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5411.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | DO Signal Source
destination | Export Desination

◆ Clear()

void JY5411.DOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5411.DOSignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • D:/5411/C#/JY5411DOTask.cs


5411 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5411 |
C JY5411DITask |
C DIChannel |
C DISampleClock | Sample clock configuration class
C DIExternalSampleClock | External Sample Clock Configuration Class
C DITrigger |
C DIDigitalTrigger |
C DISignalExport | DI Signal Export Class
C DIRecord | AI Record Parameters
C JY5411DOTask | DOTask class
C DOChannel | DOChannel class
C DOSampleClock | Sample clock configuration class
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOTrigger | DOTrigger enumeration type
C DODigitalTrigger | DODigitalTrigger enumeration type
C DOSignalExport | DO Signal Export Class


5411 C# Programming Manual: Member List

  • DIChannel
JY5411.DIChannel Member List

This is the complete list of members for JY5411.DIChannel, including all inherited members.

LineNum JY5411.DIChannel


5411 C# Programming Manual: Member List

  • DIDigitalTrigger
JY5411.DIDigitalTrigger Member List

This is the complete list of members for JY5411.DIDigitalTrigger, including all inherited members.

Edge | JY5411.DIDigitalTrigger
Source | JY5411.DIDigitalTrigger


5411 C# Programming Manual: Member List

  • DIExternalSampleClock
JY5411.DIExternalSampleClock Member List

This is the complete list of members for JY5411.DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5411.DIExternalSampleClock
Terminal | JY5411.DIExternalSampleClock


5411 C# Programming Manual: Member List

  • DIRecord
JY5411.DIRecord Member List

This is the complete list of members for JY5411.DIRecord, including all inherited members.

FileFormat | JY5411.DIRecord
FilePath | JY5411.DIRecord
Length | JY5411.DIRecord
Mode | JY5411.DIRecord


5411 C# Programming Manual: Member List

  • DISampleClock
JY5411.DISampleClock Member List

This is the complete list of members for JY5411.DISampleClock, including all inherited members.

Edge | JY5411.DISampleClock
External | JY5411.DISampleClock
Source | JY5411.DISampleClock


5411 C# Programming Manual: Member List

  • DISignalExport
JY5411.DISignalExport Member List

This is the complete list of members for JY5411.DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5411.DISignalExport
Add(DISignalExportSource source, List< SignalExportDestination > destinations) | JY5411.DISignalExport
Clear(SignalExportDestination destination) | JY5411.DISignalExport
ClearAll() | JY5411.DISignalExport


5411 C# Programming Manual: Member List

  • DITrigger
JY5411.DITrigger Member List

This is the complete list of members for JY5411.DITrigger, including all inherited members.

Delay | JY5411.DITrigger
Digital | JY5411.DITrigger
Mode | JY5411.DITrigger
PreTriggerSamples | JY5411.DITrigger
ReTriggerCount | JY5411.DITrigger
Type | JY5411.DITrigger


5411 C# Programming Manual: Member List

  • DOChannel
JY5411.DOChannel Member List

This is the complete list of members for JY5411.DOChannel, including all inherited members.

LineNum JY5411.DOChannel


5411 C# Programming Manual: Member List

  • DODigitalTrigger
JY5411.DODigitalTrigger Member List

This is the complete list of members for JY5411.DODigitalTrigger, including all inherited members.

Edge | JY5411.DODigitalTrigger
Source | JY5411.DODigitalTrigger


5411 C# Programming Manual: Member List

  • DOExternalSampleClock
JY5411.DOExternalSampleClock Member List

This is the complete list of members for JY5411.DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5411.DOExternalSampleClock
Terminal | JY5411.DOExternalSampleClock


5411 C# Programming Manual: Member List

  • DOSampleClock
JY5411.DOSampleClock Member List

This is the complete list of members for JY5411.DOSampleClock, including all inherited members.

Edge | JY5411.DOSampleClock
External | JY5411.DOSampleClock
Source | JY5411.DOSampleClock


5411 C# Programming Manual: Member List

  • DOSignalExport
JY5411.DOSignalExport Member List

This is the complete list of members for JY5411.DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5411.DOSignalExport
Add(DOSignalExportSource source, List< SignalExportDestination > destinations) | JY5411.DOSignalExport
Clear(SignalExportDestination destination) | JY5411.DOSignalExport
ClearAll() | JY5411.DOSignalExport


5411 C# Programming Manual: Member List

  • DOTrigger
JY5411.DOTrigger Member List

This is the complete list of members for JY5411.DOTrigger, including all inherited members.

Delay | JY5411.DOTrigger
Digital | JY5411.DOTrigger
Type | JY5411.DOTrigger


5411 C# Programming Manual: Member List

  • JY5411DITask
JY5411.JY5411DITask Member List

This is the complete list of members for JY5411.JY5411DITask, including all inherited members.

AddChannel(int lineNum) | JY5411.JY5411DITask
AddChannel(int[] linesNum) | JY5411.JY5411DITask
AvailableSamples | JY5411.JY5411DITask
BufLenInSamples | JY5411.JY5411DITask
Channels | JY5411.JY5411DITask
Device | JY5411.JY5411DITask
GetRecordPreviewData(ref uint[] buf, int samplesPerChannel, int timeout=1000) | JY5411.JY5411DITask
GetRecordPreviewData(ref uint[] buf, int timeout=1000) | JY5411.JY5411DITask
GetRecordPreviewData(ref byte[,] buf, int samplesPerChannel, int timeout=1000) | JY5411.JY5411DITask
GetRecordPreviewData(ref byte[] buf, uint samplesPerChannel, int timeout=1000) | JY5411.JY5411DITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY5411.JY5411DITask
JY5411DITask(int slotNum) | JY5411.JY5411DITask
JY5411DITask(string boardName) | JY5411.JY5411DITask
Mode | JY5411.JY5411DITask
ReadData(ref uint[] buf, uint samplesToAcquire, int timeOut=10000) | JY5411.JY5411DITask
ReadData(IntPtr buf, uint samplesToAcquire, int timeOut=10000) | JY5411.JY5411DITask
ReadData(ref uint[] buf, int timeOut=10000) | JY5411.JY5411DITask
ReadData(ref byte[,] buf, uint samplesPerChannel, int timeOut) | JY5411.JY5411DITask
ReadData(ref byte[] buf, uint samplesPerChannel, int timeOut) | JY5411.JY5411DITask
ReadSinglePoint(ref bool[] readValues) | JY5411.JY5411DITask
ReadSinglePoint(ref bool readValue, int lineNum) | JY5411.JY5411DITask
Record | JY5411.JY5411DITask
RemoveChannel(int lineNum) | JY5411.JY5411DITask
SampleClock | JY5411.JY5411DITask
SampleRate | JY5411.JY5411DITask
SamplesToAcquire | JY5411.JY5411DITask
SendSoftwareTrigger() | JY5411.JY5411DITask
SignalExport | JY5411.JY5411DITask
Start() | JY5411.JY5411DITask
Stop() | JY5411.JY5411DITask
TransferedSamples | JY5411.JY5411DITask
Trigger | JY5411.JY5411DITask


5411 C# Programming Manual: Member List

  • JY5411DOTask
JY5411.JY5411DOTask Member List

This is the complete list of members for JY5411.JY5411DOTask, including all inherited members.

AddChannel(int lineNum) | JY5411.JY5411DOTask
AddChannel(int[] linesNum) | JY5411.JY5411DOTask
availableLenInSamples | JY5411.JY5411DOTask
BufLenInSamples | JY5411.JY5411DOTask
Channels | JY5411.JY5411DOTask
Device | JY5411.JY5411DOTask
JY5411DOTask(int slotNum) | JY5411.JY5411DOTask
JY5411DOTask(string boardName) | JY5411.JY5411DOTask
Mode | JY5411.JY5411DOTask
RemoveChannel(int lineNum) | JY5411.JY5411DOTask
SampleClock | JY5411.JY5411DOTask
SamplesToUpdate | JY5411.JY5411DOTask
SendSoftwareTrigger() | JY5411.JY5411DOTask
SignalExport | JY5411.JY5411DOTask
Start() | JY5411.JY5411DOTask
Stop() | JY5411.JY5411DOTask
TransferedSamples | JY5411.JY5411DOTask
Trigger | JY5411.JY5411DOTask
UpdateRate | JY5411.JY5411DOTask
WaitUntilDone() | JY5411.JY5411DOTask
WriteData(uint[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5411.JY5411DOTask
WriteData(IntPtr dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5411.JY5411DOTask
WriteData(uint[] dataBuffer, int timeOut=10000) | JY5411.JY5411DOTask
WriteData(byte[,] dataBuffer, uint samplesPerChannel, int timeOut=10000) | JY5411.JY5411DOTask
WriteData(byte[] dataBuffer, uint samplesPerChannel, int timeOut=10000) | JY5411.JY5411DOTask
WriteSinglePoint(bool[] writeValues) | JY5411.JY5411DOTask
WriteSinglePoint(bool writeValue, int lineNum) | JY5411.JY5411DOTask


5411 C# Programming Manual: Class Index

Class Index
D | J
D
DIChannel (JY5411)
DIDigitalTrigger (JY5411)
DIExternalSampleClock (JY5411)
DIRecord (JY5411)
DISampleClock (JY5411)
DISignalExport (JY5411)
DITrigger (JY5411)
DOChannel (JY5411)
DODigitalTrigger (JY5411)
DOExternalSampleClock (JY5411)
DOSampleClock (JY5411)
DOSignalExport (JY5411)
DOTrigger (JY5411)
J
JY5411DITask (JY5411)
JY5411DOTask (JY5411)


5411 C# Programming Manual: D:/5411 Directory Reference

  • D:
  • 5411
5411 Directory Reference

Directories

directory C#


5411 C# Programming Manual: D: Directory Reference

  • D:
D: Directory Reference

Directories

directory 5411


5411 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 1234]
▼ D:
▼ 5411
▼ C#
JY5411DITask.cs
JY5411DOTask.cs


5411 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • Add() : JY5411.DISignalExport , JY5411.DOSignalExport
  • AddChannel() : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • availableLenInSamples : JY5411.JY5411DOTask
  • AvailableSamples : JY5411.JY5411DITask

- b -

  • BufLenInSamples : JY5411.JY5411DITask , JY5411.JY5411DOTask

- c -

  • Channels : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Clear() : JY5411.DISignalExport , JY5411.DOSignalExport
  • ClearAll() : JY5411.DISignalExport , JY5411.DOSignalExport

- d -

  • Delay : JY5411.DITrigger , JY5411.DOTrigger
  • Device : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Digital : JY5411.DITrigger , JY5411.DOTrigger

- e -

  • Edge : JY5411.DIDigitalTrigger , JY5411.DISampleClock , JY5411.DODigitalTrigger , JY5411.DOSampleClock
  • ExpectedRate : JY5411.DIExternalSampleClock , JY5411.DOExternalSampleClock
  • External : JY5411.DISampleClock , JY5411.DOSampleClock

- f -

  • FileFormat : JY5411.DIRecord
  • FilePath : JY5411.DIRecord

- g -

  • GetRecordPreviewData() : JY5411.JY5411DITask
  • GetRecordStatus() : JY5411.JY5411DITask

- j -

  • JY5411DITask() : JY5411.JY5411DITask
  • JY5411DOTask() : JY5411.JY5411DOTask

- l -

  • Length : JY5411.DIRecord
  • LineNum : JY5411.DIChannel , JY5411.DOChannel

- m -

  • Mode : JY5411.DIRecord , JY5411.DITrigger , JY5411.JY5411DITask , JY5411.JY5411DOTask

- p -

  • PreTriggerSamples : JY5411.DITrigger

- r -

  • ReadData() : JY5411.JY5411DITask
  • ReadSinglePoint() : JY5411.JY5411DITask
  • Record : JY5411.JY5411DITask
  • RemoveChannel() : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • ReTriggerCount : JY5411.DITrigger

- s -

  • SampleClock : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • SampleRate : JY5411.JY5411DITask
  • SamplesToAcquire : JY5411.JY5411DITask
  • SamplesToUpdate : JY5411.JY5411DOTask
  • SendSoftwareTrigger() : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • SignalExport : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Source : JY5411.DIDigitalTrigger , JY5411.DISampleClock , JY5411.DODigitalTrigger , JY5411.DOSampleClock
  • Start() : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Stop() : JY5411.JY5411DITask , JY5411.JY5411DOTask

- t -

  • Terminal : JY5411.DIExternalSampleClock , JY5411.DOExternalSampleClock
  • TransferedSamples : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Trigger : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Type : JY5411.DITrigger , JY5411.DOTrigger

- u -

  • UpdateRate : JY5411.JY5411DOTask

- w -

  • WaitUntilDone() : JY5411.JY5411DOTask
  • WriteData() : JY5411.JY5411DOTask
  • WriteSinglePoint() : JY5411.JY5411DOTask


5411 C# Programming Manual: Class Members - Functions

- a -

  • Add() : JY5411.DISignalExport , JY5411.DOSignalExport
  • AddChannel() : JY5411.JY5411DITask , JY5411.JY5411DOTask

- c -

  • Clear() : JY5411.DISignalExport , JY5411.DOSignalExport
  • ClearAll() : JY5411.DISignalExport , JY5411.DOSignalExport

- g -

  • GetRecordPreviewData() : JY5411.JY5411DITask
  • GetRecordStatus() : JY5411.JY5411DITask

- j -

  • JY5411DITask() : JY5411.JY5411DITask
  • JY5411DOTask() : JY5411.JY5411DOTask

- r -

  • ReadData() : JY5411.JY5411DITask
  • ReadSinglePoint() : JY5411.JY5411DITask
  • RemoveChannel() : JY5411.JY5411DITask , JY5411.JY5411DOTask

- s -

  • SendSoftwareTrigger() : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Start() : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Stop() : JY5411.JY5411DITask , JY5411.JY5411DOTask

- w -

  • WaitUntilDone() : JY5411.JY5411DOTask
  • WriteData() : JY5411.JY5411DOTask
  • WriteSinglePoint() : JY5411.JY5411DOTask


5411 C# Programming Manual: Class Members - Properties

- a -

  • availableLenInSamples : JY5411.JY5411DOTask
  • AvailableSamples : JY5411.JY5411DITask

- b -

  • BufLenInSamples : JY5411.JY5411DITask , JY5411.JY5411DOTask

- c -

  • Channels : JY5411.JY5411DITask , JY5411.JY5411DOTask

- d -

  • Delay : JY5411.DITrigger , JY5411.DOTrigger
  • Device : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Digital : JY5411.DITrigger , JY5411.DOTrigger

- e -

  • Edge : JY5411.DIDigitalTrigger , JY5411.DISampleClock , JY5411.DODigitalTrigger , JY5411.DOSampleClock
  • ExpectedRate : JY5411.DIExternalSampleClock , JY5411.DOExternalSampleClock
  • External : JY5411.DISampleClock , JY5411.DOSampleClock

- f -

  • FileFormat : JY5411.DIRecord
  • FilePath : JY5411.DIRecord

- l -

  • Length : JY5411.DIRecord
  • LineNum : JY5411.DIChannel , JY5411.DOChannel

- m -

  • Mode : JY5411.DIRecord , JY5411.DITrigger , JY5411.JY5411DITask , JY5411.JY5411DOTask

- p -

  • PreTriggerSamples : JY5411.DITrigger

- r -

  • Record : JY5411.JY5411DITask
  • ReTriggerCount : JY5411.DITrigger

- s -

  • SampleClock : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • SampleRate : JY5411.JY5411DITask
  • SamplesToAcquire : JY5411.JY5411DITask
  • SamplesToUpdate : JY5411.JY5411DOTask
  • SignalExport : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Source : JY5411.DIDigitalTrigger , JY5411.DISampleClock , JY5411.DODigitalTrigger , JY5411.DOSampleClock

- t -

  • Terminal : JY5411.DIExternalSampleClock , JY5411.DOExternalSampleClock
  • TransferedSamples : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Trigger : JY5411.JY5411DITask , JY5411.JY5411DOTask
  • Type : JY5411.DITrigger , JY5411.DOTrigger

- u -

  • UpdateRate : JY5411.JY5411DOTask


5411 C# Programming Manual: Main Page

5411 C# Programming Manual Documentation


5411 C# Programming Manual: JY5411 Namespace Reference

Classes | Enumerations
JY5411 Namespace Reference

Classes

class | JY5411DITask
class | DIChannel
class | DISampleClock
Sample clock configuration class More...
class | DIExternalSampleClock
External Sample Clock Configuration Class More...
class | DITrigger
class | DIDigitalTrigger
class | DISignalExport
DI Signal Export Class More...
class | DIRecord
AI Record Parameters. More...
class | JY5411DOTask
DOTask class More...
class | DOChannel
DOChannel class More...
class | DOSampleClock
Sample clock configuration class More...
class | DOExternalSampleClock
External Sample Clock Configuration Class More...
class | DOTrigger
DOTrigger enumeration type More...
class | DODigitalTrigger
DODigitalTrigger enumeration type More...
class | DOSignalExport
DO Signal Export Class More...

Enumerations

enum class | DIMode { Single = JY5411Import.JY5411_DI_Single , Finite = JY5411Import.JY5411_DI_Finite , Continuous = JY5411Import.JY5411_DI_Continuous , Record = JY5411Import.JY5411_DI_Record }
enum class | DISampleClockSource { Internal = JY5411Import.JY5411_DIO_InternalSampleClock , External = JY5411Import.JY5411_DIO_ExternalSampleClock }
enum class ClockTerminal {
PXIe_DStarA = JY5411Import.JY5411_DIO_PXIe_DStarA , PXIe_DStarB = JY5411Import.JY5411_DIO_PXIe_DStarB , PXI_Star = JY5411Import.JY5411_DIO_PXI_Star , PXIe_Sync100 = JY5411Import.JY5411_DIO_PXIe_SYNC100 ,
PXI_Trig0 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_0 , PXI_Trig1 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_1 , PXI_Trig2 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_2 , PXI_Trig3 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_3 ,
PXI_Trig4 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_4 , PXI_Trig5 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_5 , PXI_Trig6 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_6 , PXI_Trig7 = JY5411Import.JY5411_DIO_ExternalClock_PXITrigger_7 ,
PFI0 = JY5411Import.JY5411_DIO_ExternalClock_PFI0 , PFI1 = JY5411Import.JY5411_DIO_ExternalClock_PFI_1 , PFI2 = JY5411Import.JY5411_DIO_ExternalClock_PFI_2 , PFI3 = JY5411Import.JY5411_DIO_ExternalClock_PFI_3 ,
PFI4 = JY5411Import.JY5411_DIO_ExternalClock_PFI_4 , PFI5 = JY5411Import.JY5411_DIO_ExternalClock_PFI_5 , PFI6 = JY5411Import.JY5411_DIO_ExternalClock_PFI_6 , PFI7 = JY5411Import.JY5411_DIO_ExternalClock_PFI_7 ,
DI_SampleClock = JY5411Import.JY5411_DI_SampleClock_Out , DO_SampleClock = JY5411Import.JY5411_DO_SampleClock_Out
}
External Sample Clock Terminal More...
enum class | ClockEdge { Rising = JY5411Import.JY5411_RISING_EDGE , Falling = JY5411Import.JY5411_FALLING_EDGE }
ClockEdge enumeration type More...
enum class | DITriggerType { Immediately = JY5411Import.JY5411_TriggerType_Immediately , Digital = JY5411Import.JY5411_TriggerType_Digital , Soft = JY5411Import.JY5411_TriggerType_Soft }
enum class | DITriggerMode { Start = JY5411Import.JY5411_DI_StartTrigger , Reference = JY5411Import.JY5411_DI_ReferenceTrigger }
enum class DIDigitalTriggerSource {
PFI0 = JY5411Import.JY5411_DigitalTriggerSource_PFI0 , PFI1 = JY5411Import.JY5411_DigitalTriggerSource_PFI_1 , PFI2 = JY5411Import.JY5411_DigitalTriggerSource_PFI_2 , PFI3 = JY5411Import.JY5411_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5411Import.JY5411_DigitalTriggerSource_PFI_4 , PFI5 = JY5411Import.JY5411_DigitalTriggerSource_PFI_5 , PFI6 = JY5411Import.JY5411_DigitalTriggerSource_PFI_6 , PFI7 = JY5411Import.JY5411_DigitalTriggerSource_PFI_7 ,
PXI_Trig0 = JY5411Import.JY5411_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5411Import.JY5411_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5411Import.JY5411_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5411Import.JY5411_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5411Import.JY5411_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5411Import.JY5411_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5411Import.JY5411_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5411Import.JY5411_DigitalTriggerSource_PXI_7 ,
DO_StartTrig = JY5411Import.JY5411_DO_StartTriggerOut
}
enum class | DIDigitalTriggerEdge { Rising = JY5411Import.JY5411_DigitalTriggerEdge_Rising , Falling = JY5411Import.JY5411_DigitalTriggerEdge_Falling }
enum class | DISignalExportSource { SampleClock = JY5411Import.JY5411_DI_SampleCLK_Out , StartTrig = JY5411Import.JY5411_DI_Start_trigger_out , ReferenceTrig = JY5411Import.JY5411_DI_Reference_trigger_out }
enum class SignalExportDestination {
PFI0 = JY5411Import.JY5411_Terminal_PFI_0 , PFI1 = JY5411Import.JY5411_Terminal_PFI_1 , PFI2 = JY5411Import.JY5411_Terminal_PFI_2 , PFI3 = JY5411Import.JY5411_Terminal_PFI_3 ,
PFI4 = JY5411Import.JY5411_Terminal_PFI_4 , PFI5 = JY5411Import.JY5411_Terminal_PFI_5 , PFI6 = JY5411Import.JY5411_Terminal_PFI_6 , PFI7 = JY5411Import.JY5411_Terminal_PFI_7 ,
PXI_Trig0 = JY5411Import.JY5411_Terminal_PXITriggerBus0 , PXI_Trig1 = JY5411Import.JY5411_Terminal_PXITriggerBus1 , PXI_Trig2 = JY5411Import.JY5411_Terminal_PXITriggerBus2 , PXI_Trig3 = JY5411Import.JY5411_Terminal_PXITriggerBus3 ,
PXI_Trig4 = JY5411Import.JY5411_Terminal_PXITriggerBus4 , PXI_Trig5 = JY5411Import.JY5411_Terminal_PXITriggerBus5 , PXI_Trig6 = JY5411Import.JY5411_Terminal_PXITriggerBus6 , PXI_Trig7 = JY5411Import.JY5411_Terminal_PXITriggerBus7
}
enum class | FileFormat { Bin }
Streaming file format. enum BIN. More...
enum class | RecordMode { Finite , Infinite }
stream mode .enum Finite/Infinite More...
enum class | DOSampleClockSource { Internal = JY5411Import.JY5411_DIO_InternalSampleClock , External = JY5411Import.JY5411_DIO_ExternalSampleClock }
enum class | DOMode { Single = JY5411Import.JY5411_DO_Single , Finite = JY5411Import.JY5411_DO_Finite , ContinuousWrapping = JY5411Import.JY5411_DO_ContinuousWrapping , ContinuousNoWrapping = JY5411Import.JY5411_DO_ContinuousNoWrapping }
DOTask mode enumeration type More...
enum class | DODigitalTriggerEdge { Rising = JY5411Import.JY5411_DigitalTriggerEdge_Rising , Falling = JY5411Import.JY5411_DigitalTriggerEdge_Falling }
DODigitalTriggerEdge enumeration type More...
enum class DODigitalTriggerSource {
PFI0 = JY5411Import.JY5411_DigitalTriggerSource_PFI0 , PFI1 = JY5411Import.JY5411_DigitalTriggerSource_PFI_1 , PFI2 = JY5411Import.JY5411_DigitalTriggerSource_PFI_2 , PFI3 = JY5411Import.JY5411_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5411Import.JY5411_DigitalTriggerSource_PFI_4 , PFI5 = JY5411Import.JY5411_DigitalTriggerSource_PFI_5 , PFI6 = JY5411Import.JY5411_DigitalTriggerSource_PFI_6 , PFI7 = JY5411Import.JY5411_DigitalTriggerSource_PFI_7 ,
PXI_Trig0 = JY5411Import.JY5411_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5411Import.JY5411_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5411Import.JY5411_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5411Import.JY5411_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5411Import.JY5411_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5411Import.JY5411_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5411Import.JY5411_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5411Import.JY5411_DigitalTriggerSource_PXI_7 ,
DI_StartTrig = JY5411Import.JY5411_DI_StartTriggerOut , DI_ReferenceTrig = JY5411Import.JY5411_DI_ReferenceTriggerOut
}
DODigitalTriggerSource enumeration type More...
enum class | DOTriggerType { Immediately = JY5411Import.JY5411_TriggerType_Immediately , Digital = JY5411Import.JY5411_TriggerType_Digital , Soft = JY5411Import.JY5411_TriggerType_Soft }
DOTriggerType enumeration type More...
enum class | DOSignalExportSource { SampleClock = JY5411Import.JY5411_DO_SampleClock_Out , StartTrig = JY5411Import.JY5411_DO_StartTriggerOut }
JY5411_DO_SourceSignal More...

Enumeration Type Documentation

◆ ClockEdge

enum JY5411.ClockEdge
strong

ClockEdge enumeration type

Enumerator
Rising | Rising
Falling | Falling

◆ ClockTerminal

enum JY5411.ClockTerminal
strong

External Sample Clock Terminal

Enumerator
PXIe_DStarA | PXIeDStarA
PXIe_DStarB | PXIeDStarB
PXI_Star | PXIStar
PXIe_Sync100 | SYNC100
PXI_Trig0 | External clock PXITriggerBus0
PXI_Trig1 | External clock PXITriggerBus1
PXI_Trig2 | External clock PXITriggerBus2
PXI_Trig3 | External clock PXITriggerBus3
PXI_Trig4 | External clock PXITriggerBus4
PXI_Trig5 | External clock PXITriggerBus5
PXI_Trig6 | External clock PXITriggerBus6
PXI_Trig7 | External clock PXITriggerBus7
PFI0 | External clock PXITriggerPFI0
PFI1 | External clock PXITriggerPFI1
PFI2 | External clock PXITriggerPFI2
PFI3 | External clock PXITriggerPFI3
PFI4 | External clock PXITriggerPFI4
PFI5 | External clock PXITriggerPFI5
PFI6 | External clock PXITriggerPFI6
PFI7 | External clock PXITriggerPFI7
DI_SampleClock | DI_SampleClock
DO_SampleClock | DO_SampleClock

◆ DIDigitalTriggerEdge

enum JY5411.DIDigitalTriggerEdge
strong

数字触发边沿

DI digital trigger edge definition

Enumerator
Rising | Rising
Falling | Falling

◆ DIDigitalTriggerSource

enum JY5411.DIDigitalTriggerSource
strong

数字触发源

DI digital trigger source definition

Enumerator
PFI0 | PFI0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PXI_Trig0 | PXITrig_0
PXI_Trig1 | PXITrig_1
PXI_Trig2 | PXITrig_2
PXI_Trig3 | PXITrig_3
PXI_Trig4 | PXITrig_4
PXI_Trig5 | PXITrig_5
PXI_Trig6 | PXITrig_6
PXI_Trig7 | PXITrig_7
DO_StartTrig | DO_Start_Trig

◆ DIMode

enum JY5411.DIMode
strong

DI 模式

DIMode

Enumerator
Single | 单点模式 Single mode
Finite | 有限点模式 Finite mode
Continuous | 连续模式 Continuous mode
Record | Record

◆ DISampleClockSource

enum JY5411.DISampleClockSource
strong

时钟源

DITask ClockSource enumeration type

Enumerator
Internal | 内部时钟 Internal board clock
External | External

◆ DISignalExportSource

enum JY5411.DISignalExportSource
strong

源信号

JY5411_DI_SourceSignal

Enumerator
SampleClock | DI_SampleClock
StartTrig | DI_Start_trigger
ReferenceTrig | DI_Reference_trigger

◆ DITriggerMode

enum JY5411.DITriggerMode
strong

触发模式

DITask DITriggerMode enumeration type

Enumerator
Start | Start
Reference | Reference

◆ DITriggerType

enum JY5411.DITriggerType
strong

触发类型

DITask DITriggerType enumeration type

Enumerator
Immediately | Immediate
Digital | Digital
Soft | Soft

◆ DODigitalTriggerEdge

enum JY5411.DODigitalTriggerEdge
strong

DODigitalTriggerEdge enumeration type

Enumerator
Rising | Rising
Falling | Falling

◆ DODigitalTriggerSource

enum JY5411.DODigitalTriggerSource
strong

DODigitalTriggerSource enumeration type

Enumerator
PFI0 | PFI0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PXI_Trig0 | PXITrig_0
PXI_Trig1 | PXITrig_1
PXI_Trig2 | PXITrig_2
PXI_Trig3 | PXITrig_3
PXI_Trig4 | PXITrig_4
PXI_Trig5 | PXITrig_5
PXI_Trig6 | PXITrig_6
PXI_Trig7 | PXITrig_7
DI_StartTrig | DI_Start_Trig
DI_ReferenceTrig | DI_Reference_Trig

◆ DOMode

enum JY5411.DOMode
strong

DOTask mode enumeration type

Enumerator
Single | Single mode
Finite | Finite mode
ContinuousWrapping | ContinuousWrapping mode
ContinuousNoWrapping | ContinuousNoWrapping mode

◆ DOSampleClockSource

enum JY5411.DOSampleClockSource
strong

时钟源

DOTask ClockSource enumeration type

Enumerator
Internal | 内部时钟 Internal board clock
External | External

◆ DOSignalExportSource

enum JY5411.DOSignalExportSource
strong

JY5411_DO_SourceSignal

Enumerator
SampleClock | DO_SampleCLK_Out
StartTrig | DO_Start_trigger_out

◆ DOTriggerType

enum JY5411.DOTriggerType
strong

DOTriggerType enumeration type

Enumerator
Immediately | Immediate
Digital | Digital
Soft | Soft

◆ FileFormat

enum JY5411.FileFormat
strong

Streaming file format. enum BIN.

Enumerator
Bin

BIN。

BIN.

◆ RecordMode

enum JY5411.RecordMode
strong

stream mode .enum Finite/Infinite

Enumerator
Finite | Finite Streaming
Infinite | Infinite Streaming

◆ SignalExportDestination

enum JY5411.SignalExportDestination
strong

目的信号

JY5411_DestinationTerminal

Enumerator
PFI0 | DestinationTerminal_PFI0
PFI1 | DestinationTerminal_PFI1
PFI2 | DestinationTerminal_PFI2
PFI3 | DestinationTerminal_PFI3
PFI4 | DestinationTerminal_PFI4
PFI5 | DestinationTerminal_PFI5
PFI6 | DestinationTerminal_PFI6
PFI7 | DestinationTerminal_PFI7
PXI_Trig0 | DestinationTerminal_PXITriggerBus0
PXI_Trig1 | DestinationTerminal_PXITriggerBus1
PXI_Trig2 | DestinationTerminal_PXITriggerBus2
PXI_Trig3 | DestinationTerminal_PXITriggerBus3
PXI_Trig4 | DestinationTerminal_PXITriggerBus4
PXI_Trig5 | DestinationTerminal_PXITriggerBus5
PXI_Trig6 | DestinationTerminal_PXITriggerBus6
PXI_Trig7 | DestinationTerminal_PXITriggerBus7


5411 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:
  • ClockEdge : JY5411
  • ClockTerminal : JY5411
  • DIDigitalTriggerEdge : JY5411
  • DIDigitalTriggerSource : JY5411
  • DIMode : JY5411
  • DISampleClockSource : JY5411
  • DISignalExportSource : JY5411
  • DITriggerMode : JY5411
  • DITriggerType : JY5411
  • DODigitalTriggerEdge : JY5411
  • DODigitalTriggerSource : JY5411
  • DOMode : JY5411
  • DOSampleClockSource : JY5411
  • DOSignalExportSource : JY5411
  • DOTriggerType : JY5411
  • FileFormat : JY5411
  • RecordMode : JY5411
  • SignalExportDestination : JY5411


5411 C# Programming Manual: Package Functions

  • ClockEdge : JY5411
  • ClockTerminal : JY5411
  • DIDigitalTriggerEdge : JY5411
  • DIDigitalTriggerSource : JY5411
  • DIMode : JY5411
  • DISampleClockSource : JY5411
  • DISignalExportSource : JY5411
  • DITriggerMode : JY5411
  • DITriggerType : JY5411
  • DODigitalTriggerEdge : JY5411
  • DODigitalTriggerSource : JY5411
  • DOMode : JY5411
  • DOSampleClockSource : JY5411
  • DOSignalExportSource : JY5411
  • DOTriggerType : JY5411
  • FileFormat : JY5411
  • RecordMode : JY5411
  • SignalExportDestination : JY5411


5411 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY5411 |
C JY5411DITask |
C DIChannel |
C DISampleClock | Sample clock configuration class
C DIExternalSampleClock | External Sample Clock Configuration Class
C DITrigger |
C DIDigitalTrigger |
C DISignalExport | DI Signal Export Class
C DIRecord | AI Record Parameters
C JY5411DOTask | DOTask class
C DOChannel | DOChannel class
C DOSampleClock | Sample clock configuration class
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOTrigger | DOTrigger enumeration type
C DODigitalTrigger | DODigitalTrigger enumeration type
C DOSignalExport | DO Signal Export Class